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ClayTools®	version	3	

A Guide to What’s New in This Release  
  
This document provides a brief summary of the new features and enhancements that are available in 
version 3.  
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Snap to Curves Through Objects 

An option has been added to the View > Curves menu, Snap to Curves Through Objects. This 
option is on/selected by default. Use this option to haptically snap to curves through objects. You 
can only adjust this option if See Curves Through Objects is on (selected) in the View > Curves. 

Split Curve 

The Split Curve tool has been enhanced. In previous versions of ClayTools, the dynabar Tolerance 
setting was used only for the Split itself, connecting endpoints in the result. In V3, after splitting, the 
tool will connect all regional endpoints at the location of the split (within the split tolerance 
parameter). All curves will be modified as needed to achieve a single juncture at each split 
location.  

Trace Mode 

Trace Mode, available through the Advanced options on the Draw Curve dynabar, now has a hot 
key to toggle the mode. To toggle trace mode without opening the advanced options, press 
Ctrl+Shift+T. 

DEFORM CLAY 

Tug 

The Tug tool has been enhanced with a new dynabar options: 

Restrict Tug to Normal. This was added to provide more control by restricting the tug so it is 
normal to the surface of the clay at the initial tug point. 

Axis Snap has been added with the ability to align the haptic guides to the Global, Piece-Local, 
Current View, Selected Plane and Surface Normal as coordinate systems. The setting does not 
affect axis snapping in Tools/Features that do not have the new menu button. If you are using 
Selected Plane, you must either select the plane before entering the tool or select the plane using 
the Object List. To access these options, click the arrow in the top left corner of the Axis Snap icon. 

Ruler Snap Detents Now, you also have the ability to suppress the haptic snap of ruler spacing. 
The tugged clay will be constrained to the Incremental Snap Detent (set in Ruler Spacing) as well 
as the normal vector. However, by pressing and holding the Alt key, you are able to suppress the 
Incremental Snap Detent when pushing or pulling the clay, allowing for smooth modifications along 
the normal vector guide while still getting a distance readout. You will have to "break" off the vector 
to move the clay freely. 

Tug Area 

The Tug Area tool has been both enhanced and modified to meet the differing needs of varied 
workflows. Read on for more information.  

Enhancements 

Manual Seed Point This gives you the ability to tell the application which area will be tugged. Off 
by default. 
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Axis Snap is a new option on the dynabar to provide more control by giving the ability to haptically 
align your movements to either the X, Y, or Z axes. When you move the PHANTOM device tool, 
you'll feel a slight stick when the tool is aligned with any of the axes. 

When using Axis Snap in Tug Area you have the ability to align the haptic guides to the Global, 
Piece-Local, Current View, Selected Plane and Surface Normal as coordinate systems. The setting 
does not affect axis snapping in Tools/Features that do not have the new menu button. If you are 
using Selected Plane, you must either select the plane before entering the tool or select the plane 
using the Object List. To access these options, click the arrow in the top left corner of the Axis 
Snap icon. 

Ruler Snap Detents. The tugged clay will be constrained to the Incremental Snap Detent (set in 
Ruler Spacing) as well as the normal vector. However, by pressing and holding the Alt key, you are 
able to suppress the Incremental Snap Detent when pushing or pulling the clay, allowing for 
smooth modifications along the normal vector guide while still getting a distance readout. You will 
have to "break" off the vector to move the clay freely. 

Modifications 

Auto Apply, when selected (default behavior), the tug is automatically applied and the model is re-
rasterized when you release the PHANTTOM stylus button and allows for “re-tugging” this is close 
to old behavior. When not checked you will need to  

If Auto Apply is not selected, you must click either Clear or Apply, which will either remove all 
modifications from the clay (Clear) or apply all of the deformations to the clay (Apply). After each 
tug you must Apply the modification or Clear the modification. If you do not, you will be prompted 
to clear or apply the tug deformations.  

Tug with Curve 

Tug with Curve has had both a new option added as well as a change in behavior. 

Taper - Tug with Curve has also been enhanced to provide the capability to define both a Start 
and End radius (ability to taper). These options have been added to the dynabar, by default there 
is only a Start radius, click the checkbox on the dynabar to use a separate end radius. You can 
type specific values for both the Start and End radii. 

Behavior Change: The Tug with Curve (Clay) tool has been enhanced to improve both the detail 
of the clay and the speed in processing the tugged clay. In previous versions of ClayTools, in some 
instances, tugging clay would result in subtle changes to the entire model or loss of detail during 
the rasterization process. The internal procedure for tugging clay has been improved to lessen 
these undesirable results. Internally, Tug with Curve now uses bounding boxes to identify the 
areas to rasterize. Clay that is outside the bounded areas will not be affected by the rasterization.  

New Recommendation: The introduction of the bounding boxes has changed the recommended 
strategy for tugging multiple curves. In previous versions, due to the possibility of losing detail on 
the model, it was best to tug all the curves and then apply all the deformations in one pass of the 
tool. With the new ability to limit the rasterization process, the recommended strategy has 
changed. If you are working with two or more curves, and the bounding boxes (areas being 
tugged) would intersect, you should tug all curves and then apply the deformations. However, if the 
curves you are using to tug the clay are far apart (the bounding boxes would not intersect) it is best 
to tug and apply the deformations for each curve separately. 
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IMPORT/EXPORT/SAVE    

Enhancements: 

Export .CLY File 

Provides the ability to save selected objects (clay, planes, curves) as a new clay file(s). By default, 
the export option, Include Associated Objects is selected. With this option selected, dependent 
objects will be included in the export. If you are exporting multiple objects, you can export each 
object as a separate file. If you select a dependent curve or plane to export, the parent clay or 
mesh piece will be included within the exported file.  

The option "Delete the selected objects from the current file" was added to the Export Model 
dialog. This option is available only when Export from Selected pieces is selected. When this 
option is checked, all selected objects will be deleted from the current file after the CLY exporting. 

When saving a single exported file of "Selected" or "Shown"entities, the exported file will be 
named, <Filename>_extracted.cly. 

When you Export as Separate Files, there is a dynabar option that provides the ability to save the 
files, using only the piece names without the filename prefix. 

You cannot save objects with duplicate names as separate files. A warning message will appear. 
You may cancel the export, and rename the duplicates, or proceed without exporting those 
objects. 

Import .AI or .PDF 

When designing in Adobe Illustrator, many curves are broken down into very small, very detailed 
segments. When these curves are imported, either as .ai or .pdf files to a plane, these segments 
are joined into one curve. In previous versions of ClayTools, when these imported objects were 
extracted, the shape was lost.  

Tip: When you are planning to copy an .ai or .pdf file to create a 3D curve, do NOT modify the 
object in sketch mode.  
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Object List Search Function 

The Object List Search Function provides the ability to find any object (clay, planes, curves) in the 
file by searching for a string of characters in the object's name. When the Object List is active you 
can open the Object List Search Function through the File Folder menu in the Object List, or open 
the search function at any time by pressing Ctrl+F. The search starts at the position of the current 
active piece. Searching the Object List is a two-step process.  

First, the search pattern is executed and the result tree is built. Second, the search results are 
selected in the Object List. If you are working with a very large file, the Find button becomes a Stop 
button, providing the ability to stop the search at its current location.  

The Object List Search Function provides the capability to find and select all of the objects 
matching your search criteria, through a check box. With this check box selected, all objects that 
meet the search criteria will become selected in the Object List. This will be useful if you are 
working with projects where you are frequently importing and exporting existing parts, such as 
library parts that share a naming convention. 

Enhancements: 

Notes 

The Object List Context Menu has been enhanced to provide easier way to remove notes, the 
option to delete a note. In previous versions, in order to delete a note you had to go to, Add Note, 
and then manually delete the contents. In version 3, there is a specific option, Delete Note. 

PLANES 

Enhancements: 

Create Plane 

There is a new option in Tools>Options>General>Features to set the plane coordinates to 0,0,0 
when planes are created in an empty model. This option is selected by default. 

Edit Plane 

The Edit Plane tool has been enhanced so that when repositioning a plane, you have control over 
the accurate positioning and location of the plane.  

Origin Triad - The plane's origin is now visually represented by a triad while in the Edit Plane tool. 

Graph Paper - The haptic graph paper is displayed on the plane based on the option chosen in 
Tools>Options, and will not change as the plane is re-sized.  

Advanced options for editing a plane have new capabilities. With the Position by Value dialog, 
you can reposition the plane relative to the plane's origin, based on the visible planes X, Y and Z 
coordinates. 
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PIECES MENU 

Enhancements: 

Duplicating Objects 

The Duplicating a Piece function now allows for duplicate pieces to be made from not only the 
active clay piece, but also from mesh pieces. Clay and Mesh objects can be duplicated through the 
Pieces Menu>Duplicate Piece or through the Object List Context Menu option, Duplicate. 

REPOSITION TOOLS  

Enhancements: 

Reposition Origin 

The Reposition Origin tool was enhanced to provide the ability to automatically orient the triad 
position. In previous versions, there was a single option for orienting the triad, Normal to Surface 
(clay). In Version 3, there are three states, Off, Normal to Surface (clay), and Normal to Active 
Plane. This new option orients the piece triad so that the Z axis points perpendicular to the active 
plane.  

Reposition Piece 

The Reposition Piece tool was enhanced. Three dynabar options were added that display a plane 
normal to the X, Y, or Z axes.  
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SELECT/MOVE CLAY 

Enhancements: 

Masking Clay 

The Mask Clay tool was enhanced to include the dynabar option, Invert. This function will invert the 
current masked selection with the unmasked selection.  

Separate 

The Separate with Curve tool has been renamed Separate and the tool has been enhanced. This 
tool now has the ability to separate clay with curves or planes. 

SKETCH 

New Features: 

Pencil, Erase Pencil and Extend/Retract Curve 

Three new tools have been added to the Sketch Palette. 

Enhancements: 

Freehand Curve - Edit 

The Freehand Curve tool has been enhanced to add functionality to display and modify the 
existing number of points in a Sketch Curve to provide the same editing capabilities as 3D curves. 
The Freehand Curve dynabar now displays and dynamically updates the number of Edit Points, 
the Current Point, and Curve Length. You can edit the number of Edit Points through this dynabar 
option, or select the Edit Point to modify through the Current Point dynabar option.  

Two new options have been added, Preserve Detail and Uniform Spacing to give more control of 
the shape. 

  



Copyright
All Rights

Mi

The
Th

 

 

t © 2011 Sens
Reserved  

rroring Ske

e Mirroring S
is option prov

sable Techno

etches 

ketches tool h
vides the capa

 

ologies, Inc. ®

has been enh
ability to make

®  

hanced with a
e any sketch 

a new dynaba
entity the mir

Las

ar option, Sele
rror line. 

In the 
here w
horizo
mirror

First w
Mirror
click t
image
horizo
mirror

Next w
Objec
of the 
mirror

Previe
box ha
added
for Mi
Objec
Desel
box w
previe
works

20 | P

st updated – 03/2

ect Mirror Line

example sho
we want to us
ontal line as th
r line. 

we click Selec
r Line option a
he curve. The

e shows that t
ontal line is th
r line. 

we click Selec
cts and click e

curves we w
r. 

ew A new che
as also been 
d to the dynab
rror Sketch 

cts, Preview. 
ecting this ch

will hide the m
ew in the 
space. 

a g e  

24/2011 

e. 

own 
se the 
he 

ct 
and 
e first 
the 
e 

ct 
each 

want to 

eck 

bar 

heck 
irror 



21 | P a g e  
Copyright © 2011 Sensable Technologies, Inc. ®  
All Rights Reserved   Last updated – 03/24/2011 

Shrink-Wrap a Sketch Plane - Hot key 

The option to Shrink-wrap a Sketch Plane, the ability to resize the Sketch Plane around the plane's 
center point to the outermost edge of the sketch object has a new hot key assignment. Press 
Alt+M to shrink-wrap the Sketch Plane. 

Sketch Curve Tangency - Display 

The Sketch Curve tangency handler (Tangency Vertex and Line) is now lighter than the Sketch 
Curve Edit Points color and the size of Tangency Vertex is now smaller then Edit Points vertex.  

Sketch Options 

Three checkboxes have been added to the Tools>Options>General>Sketch menu to provide more 
control of sketch views.  

 Sketch Mode saves/restores prior view, when selected, will return to the view in effect 
prior to entering sketch mode when you exit the Sketch tool. 

 Sketch Mode view flat to plane, when selected, will rotate the view to align flat (align 
plane's normal to view angle) when you enter the sketch tool.  

 Zoom view to fill screen, when selected, will zoom the view to the scale of the sketch 
when you enter the Sketch tool. All three of these check boxes are selected by default.  

SYSTEM 

Enhancements: 

Windows® 7 Support 

ClayTools version 3 now supports, in addition to Window XP, both Windows® 7 64 bit and 
Windows® 7 32 bit operating systems. 
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exists, or existed in the current session, it will create a new, unique name for that object. 
IMPORTANT: If you open/import a file that was saved with objects with the same name, the 
application will rename them to make unique names. 

“Create new plane at (0,0,0) if workspace is empty” When selected the plane coordinates of new 
planes created in an empty model are to 0,0,0. This option is selected by default. 

General/Temp Folder 

“Temporary file folder” The default location of the Temp Folder, which allows you to define a 
specific location to save your temporary files, has been changed. The new default location for 
temporary files is: C:\Documents and Settings\<user name>\LocalSettings\Temp\<Application 
Name>.  

 “Remove *.tmp files in the temporary file folder at launch” Select to have all temporary files 
(F*.tmp) removed at the launch of the application. If unchecked, only FEU*.tmp and FET*.tmp will 
be removed. Having the files from the TEMP folder removed at each launch may improve 
performance. 

General/Save (Formerly Backup) 

The General>Backup menu has been renamed for clarity. 

General/Save Screen 

This new menu includes options for defining the image format (.jpg or .bmp), image size, JPEG 
quality, what pieces the image will capture, and the ability to define a specified location for these 
images. 

View/Setup 

“Maintain current zoom level for standard views” has been added. When selected, the zoom level 
will be saved and applied to all views when changing to a one of the standard views.. 

View/Colors 

 “Hide paint colors on startup” This new option, when selected will hide any paint colors when a file 
that has painted pieces is opened. This option is unchecked by default. 

View/Rendering/Save See Through Settings 

“Save see through settings” This new option adds ability to save the current state of your See 
Through settings with the model. The settings will only be saved when the model is saved. When 
unchecked, the See Through settings will be removed on file save. 
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